AnyRobot-当前系统与采集时间不在告警策略统计范围内,导致智能告警无告警记录产生
简介:AnyRobot-当前系统与采集时间不在告警策略统计范围内,导致智能告警无告警记录产生,确认为数据的采集时间如果不在统计范围之内导致,可参照文档中方案解决。
关键字
智能告警、告警记录
适用产品
· AnyRobot 3.0.x
问题描述
在 AnyRobot 界面,点击智能告警 > 规则策略 > 新建,填写智能告警规则策略配置项,点击保存,如下:
点击智能告警 > 场景策略 > 新建,将上步的规则策略添加到场景策略中,点击保存,如下:
采集数据,接入可以产生告警的数据,点击智能告警 > 告警记录,没有告警记录产生,页面显示信息:
问题影响
AnyRobot 的智能告警不产生告警记录。
问题原因
告警策略中的触发条件为告警统计时间,统计时间范围为当前系统时间往前推算的一段时间,比如规则策略设置了触发条件为100秒,那么起始统计时间范围为当前系统时间减去100秒到当前系统时间截止。
数据的采集时间如果不在这个统计范围之内,就不会产生告警。
解决方案
1. 进入 AnyRobot 系统后台,输入以下命令行查看当前系统时间:
date
2. 确保系统有实时传入数据的情况下,登录 AnyRobot 界面,点击搜索,界面重新设置事件聚合时间。例中为最近 24 小时。
3. 查看当前采集数据的传入时间,检查数据时间与当前系统时间的差距。如下图,发现目前实时数据传入的数据时间和系统时间相差2小时。
4. 登录 AnyRobot 界面,点击智能告警 > 规则策略 > 编辑,重新设置触发条件的计数时间,设置3小时并保存,如下图:
5. 登录 AnyRobot 界面,点击数据源>本地上传,采集上传小于当前系统时间3小时内的数据,如下图:
6. 登录 AnyRobot 界面,点击智能告警 > 告警记录,查看产生的告警记录。
更多信息
关于智能告警操作的更多信息,请参考《AnyRobot-基于规则引擎的智能告警最佳实践》:https://www.eisoo.com/cn/support-detail/948。